Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Deletion

The best solution for finding and removing duplicate files.
Post Reply
Sean961
Posts: 4
Joined: Fri May 20, 2016 11:22 am

Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Deletion

Post by Sean961 »

I upgraded recently from Duplicate Cleaner Pro 3 to 4 and must say the searching is way faster!

However, there does seem to be a strange bug that throws my Duplicate Cleaner program to "not responding" for approximately a minute with each "Mark[ing]" of a folder for deletion. As you can imagine this is very annoying and makes something that should be rather quick quite tedious. The folder sizes are slightly over 1GB each.

Upgraded from 3 to 4 because the program would hang and go unresponsive when scanning large hard drives (1TB+) and that seems to be fixed in version 4.0, however this new issue now appears. Is it a result of using the folder selections vs file selections?

Thanks
User avatar
DigitalVolcano
Site Admin
Posts: 1350
Joined: Thu Jun 09, 2011 10:04 am

Re: Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Dele

Post by DigitalVolcano »

Do the folders have a lot of files in them?
Is is hanging when you click (or right-click) on a row?
It could be that the system is hanging because it is creating the file list in the right-hand pane - you get control back after the list appears.
This is on the 'fix list' for version 4.0.1 - the file list will generate in the background.
Sean961
Posts: 4
Joined: Fri May 20, 2016 11:22 am

Re: Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Dele

Post by Sean961 »

DigitalVolcano wrote:Do the folders have a lot of files in them?
Is is hanging when you click (or right-click) on a row?
It could be that the system is hanging because it is creating the file list in the right-hand pane - you get control back after the list appears.
This is on the 'fix list' for version 4.0.1 - the file list will generate in the background.
It hangs when I click the checkbox next to the folder and when I right-click and then select "Mark [for deletion]". Both instances cause the temporary outage.
User avatar
therube
Posts: 512
Joined: Tue Jun 28, 2011 4:38 pm

Re: Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Dele

Post by therube »

I'm not following just where this is happening?

> "Mark[ing]" of a folder for deletion

This is where, the 'Duplicate folders' tab?


> The folder sizes are slightly over 1GB each

So the accumulated file sizes of the files in the particular folder are ~1GB?


> It hangs when I click the checkbox next to the folder

I see any number of "Folder group #" entries, but I am unable to click the checkbox to left of any of them?
Now subdirectories to a particular 'Folder group', I am. (And any subdirectories to the checked subdirectory are also selected.)


> and when I right-click and then select "Mark [for deletion]"

Just where are you finding that?
Just exactly what context-menu item are you choosing?
So the [for deletion] is immaterial (to the context-menu selection, but will happen after the fact), but you're either using 'Selection assistant -> All but one in all groups, or 'Mark all folders and subfolders in list'?


> Do the folders have a lot of files in them?

?


And to be clear, there is no hang on a right-click action, only when you actually select "Mark"?
Sean961
Posts: 4
Joined: Fri May 20, 2016 11:22 am

Re: Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Dele

Post by Sean961 »

therube wrote:I'm not following just where this is happening?
...
*answers added within your post below

I'm not following just where this is happening?
"Mark[ing]" of a folder for deletion
This is where, the 'Duplicate folders' tab?

- YES


> The folder sizes are slightly over 1GB each
So the accumulated file sizes of the files in the particular folder are ~1GB?

- YES, SLIGHTLY MORE THAN 1GB


> It hangs when I click the checkbox next to the folder
I see any number of "Folder group #" entries, but I am unable to click the checkbox to left of any of them?
Now subdirectories to a particular 'Folder group', I am. (And any subdirectories to the checked subdirectory are also selected.)

- I AM REFERRING TO THE INDIVIDUAL FOLDER THAT HAS A DUPLICATE (UNDER SAME FOLDER GROUP)


> and when I right-click and then select "Mark [for deletion]"
Just where are you finding that?
Just exactly what context-menu item are you choosing?
So the [for deletion] is immaterial (to the context-menu selection, but will happen after the fact), but you're either using 'Selection assistant -> All but one in all groups, or 'Mark all folders and subfolders in list'?

- NOPE, IF YOU RIGHT-CLICK ON AN INDIVIDUAL FOLDER (ONE THAT HAS A DUPLICATE) YOU "MARK" IT PRIOR TO DELETING IT ALONG WITH THE REST OF THE "MARK[ED] FOLDERS

> Do the folders have a lot of files in them?

- THEY OFTEN DO


And to be clear, there is no hang on a right-click action, only when you actually select "Mark"?

- YES, ONLY ONCE I SELECT TO BE MARKED (ESSENTIALLY THE SAME AS CHECKING THE BOX)
User avatar
DigitalVolcano
Site Admin
Posts: 1350
Joined: Thu Jun 09, 2011 10:04 am

Re: Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Dele

Post by DigitalVolcano »

Looking into speeding this up for 4.0.2
Sean961
Posts: 4
Joined: Fri May 20, 2016 11:22 am

Re: Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Dele

Post by Sean961 »

DigitalVolcano wrote:Looking into speeding this up for 4.0.2
Awesome! Thanks so much!
gamemaster
Posts: 1
Joined: Sun Jun 05, 2016 8:35 pm

Re: Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Dele

Post by gamemaster »

Just to confirm that also in my experience 4.0.1 seems to be slower and clumsier than 3
In addition, it would be nice to be able to choose the option to have the system delete or the old delete as in 3
Now when I delete huge amount of file it always get hung for some thumbs needing permission to be deteleted. Was not happening in version 3

Thanks
dbague
Posts: 20
Joined: Mon Oct 02, 2017 6:35 pm

Re: Duplicate Cleaner Pro 4.0 Freezes on EVERY Mark for Deletion

Post by dbague »

I am actually experiencing similar symptoms, many hangs when dealing with a large cache (900MB).
I have had bigger caches in the past, and not that hanging behavior with is most visible when marking many files, such as in the folder dup.

But one the hangs (being patient the marking do occur, but software non-responsive at any level, and if pressed a windows hang message can be obtained by asking explorer to close the window (s7).

but now i wonder if it is not everywhere... aborting during a hang may corrupt the cache? and then subsequent usage of that cache lead to more diverse hangs?

am i the only one finding such behavior since the very lastest update? 4.1.4

Edit: (context)
I am trying to bring down the size of a partition content, where cumulated migrations have happened from XP to vista/7. now toward windows10 (but working on windows 7, because proper saving of hidden parameters may not have been done, and a lot of windows folder structure copying.

So in the end. all the junctions and other symlinks, seem to have been copied by content (with some recursion, btw, not my doing). so huge Appday, Application data, and local settings. twice, from 2 different drive recup in the past.) both migrations cumulated and bad symlink copying in the past.

so typically the marking in the folder dup, involved big total size and possibly big file #, and visibly many such folder to mark in one group.

and yes i have to close and drop the big cache, and go fine granularity now about this context. but looking to downgrade DVDCPro to check for same database handling... if problem persist with smaller task.
Post Reply